Forum Diskio Pi

Another digital world is possible.

Vous n'êtes pas identifié(e).

#1 03-09-2020 14:13:58

Chietsuki
Membre

[RESOLU] Problème d'alimentation SBC par la carte fille

Bonjour à tous,

Pour résumer: après différents tests il semblerait que l'alimentation SBC par la carte fille ne fonctionne pas.

La carte fille est la version 1.0 .
J'ai essayé avec les 2 câbles (micro USB et USB C) sur 2 Raspberry PI différents (un 4 et un 3).
Pour le 4 j'ai même essayé avec le câble micro USB + un adaptateur (que j'ai essayé au préalable avec une alimentation séparée). Ce n'est donc pas le problème connu des 1ères versions de RPi 4 par rapport à la reconnaissance du câble d'alimentation.

L'alimentation de l'écran est OK ainsi que celle du ventilateur.
Le voyant d'alimentation présent sur la carte fille (la LED D4) est éteint ainsi que la LED d'alimentation présente sur le RPi.

J'ai fait des tests de continuité avec un multimètre, et le connecteur SBC de la carte fille est bien connecté au 5V et GND du RPi.

Ce qui me gêne le plus est que, lorsque j'éteins de Diskio Pi, les 2 LEDs (la D4 ainsi que celle sur le RPi) s'allument puis s’éteignent aussitôt comme si un condensateur se déchargeait.


Pour le coup je ne sais plus trop quoi tester ni où regarder.
Vous n'auriez pas des pistes pour m'aider troubleshoot le problème et trouver la rootcause (surtout si c'est un composant défectueux) ?


Merci d'avance pour votre aide smile

Dernière modification par Chietsuki (03-09-2020 15:08:41)

Hors ligne

#2 03-09-2020 14:28:43

Gaara14
Administrator

Re : [RESOLU] Problème d'alimentation SBC par la carte fille

Bonjour,

Si l'écran et le ventilateur sont bien alimentés, c'est signe que l'alimentation 5V fonctionne, c'est déjà ça.
Ensuite, quelles est la position de l'interrupteur quand vous allumez la tablette ? Vers le haut ou vers le bas ?

Hors ligne

#3 03-09-2020 14:34:44

Chietsuki
Membre

Re : [RESOLU] Problème d'alimentation SBC par la carte fille

Bonjour Gaara,

Il est vers le haut.
C'est lorsque je le mets vers le bas (donc lorsque j'éteins la tablette) qu'il y a cet allumage bref des 2 LEDs.

Hors ligne

#4 03-09-2020 14:39:14

Gaara14
Administrator

Re : [RESOLU] Problème d'alimentation SBC par la carte fille

Ok, donc c'est normal smile

En réalité il y a 3 positions:
- Vers le haut : l'écran seul est alimenté, plus la sortie USB verticale. C'est pour faire fonctionner un RPi à l'extérieur de la machine.
- Milieu : tout est éteint
- Bas: l'écran est alimenté, plus le SBC interne.

Il faut donc allumer la tablette bouton vers le bas.

Selon votre montage et les aléas des impressions, la position vers le bas est peut être plus difficile à atteindre. Si ça ne passe pas, c'est qu'il y a un résidu de plastique qui gêne pour cette position, ça peut arriver.

Edit: ne forcez pas trop, le bouton est fragile (un point de plus à améliorer d'ailleurs).

Hors ligne

#5 03-09-2020 14:49:51

Chietsuki
Membre

Re : [RESOLU] Problème d'alimentation SBC par la carte fille

Ah c'était ça !
En effet la position basse est très difficile à atteindre (lorsque le bouton est en position milieu, celui-ci est presque totalement en bas de la fente présente sur la coque principale).

Merci beaucoup pour votre aide. Je ne voulais pas forcer pour ne rien casser et je devenais fou à force de ne pas trouver l'origine du problème.

Hors ligne

#6 03-09-2020 15:05:26

Gaara14
Administrator

Re : [RESOLU] Problème d'alimentation SBC par la carte fille

Ok, parfait !
Je vais mettre le wiki à jour pour prévenir le souci, et demander de tester les 3 positions du bouton avant le vissage définitif de l'interrupteur.

Si vous pouviez passer le sujet en [résolu], en modifiant le titre de votre premier message ça serait super smile
Merci !

Hors ligne

#7 18-09-2020 21:05:00

Gozer
Membre

Re : [RESOLU] Problème d'alimentation SBC par la carte fille

Salut,

J'ai rencontré le même "problème", je dirais plutôt la même difficulté.
Ce topic m'a bien aidé, parfait wink
Merci à vous deux !

Dernière modification par Gozer (18-09-2020 21:09:23)

Hors ligne

Pied de page des forums

Propulsé par FluxBB 1.5.11