Forum Diskio Pi

Another digital world is possible.

Vous n'êtes pas identifié(e).

#1 04-07-2020 11:59:46

Wiryn
Membre

Problème écran.

Bonjour à tous,

J'ai fini hier après 5 heures de montages minutieux avec X vérifications pour ne pas faire de boulettes, j'ai allumé la "BETE".

J'ai remarqué que lorsque je suis dessus, il y a un soucis je pense avec l'écran, les branchements ou autre : parfois en utilisation tactile et normale des flashs noirs et autres apparaissent sans aucune raison.

Une autre bizarrerie est que lorsque je pose le Diskio Pi à plat la sourie deviens "folle" se bloque a un endroit et doit recevoir des clics ou informations fantômes.

" Edit" J'ai revérifié les branchements, j'ai remonté et depuis 5 minutes plus aucun flash par contre quand je change l'orientation du moniteur, la souris bouge toute seule puis se stabilise.

Merci par avance

Dernière modification par Wiryn (04-07-2020 13:15:54)

Hors ligne

#2 04-07-2020 13:56:32

Gaara14
Administrator

Re : Problème écran.

Bonjour,

Je suis désolé pour ce début malheureux !
Il semblerait que ces deux défauts soient liés. Pouvez vous me dire, si, tout éteint et la tablette posée à plat, vous voyez des taches sombres sur l'écran?
Et si oui, à quel endroit ?

Guillaume

Hors ligne

#3 04-07-2020 15:27:36

Wiryn
Membre

Re : Problème écran.

Oui il y a bien des taches sombres à l'écran quand il est complètement éteint, ce n'est pas te ta faute je ne sais pas pourquoi cela fait cela tu aurais une idée ? La tache me fais une genre de arc de cercle vers le milieu supérieur de l'écran (si on coupe l'écran moitié moitié). Depuis que j'ai revérifié les branchements, il n'y a plus de coupures de l'image par contre dès que je change de position la souris deviens "folle".

Hors ligne

#4 04-07-2020 15:42:06

Gaara14
Administrator

Re : Problème écran.

D'accord, un soucis en moins, s'il n'y a plus de coupures.

Pour les taches, ça vient du fait que l'écran est en contact à certains endroits avec le verre tactile, du coup le tactile le détecte et le pointeur de souris réagit en fonction.

Normalement, il y a un espace de 1mm entre l'écran et le verre tactile. Il y a donc un point saillant derrière l'écran qui appuie contre celui ci, reste à trouver quoi.
Ça peut être un câble (batterie ou hauts parleurs), ou la plaque du Raspberry Pi. Si c'est un câble, pas de soucis, il est possible de le repositionner pour ne pas qu'il dépasse.
Si en revanche c'est la plaque du Raspberry Pi, alors il y a sans doute un défaut (qui devra être corrigé).

Pour trouver la cause, il faudrait dévisser le cadre avant (machine éteinte), et soulever délicatement l'écran pour voir ce qu'il en est exactement.

Hors ligne

#5 04-07-2020 15:55:16

Wiryn
Membre

Re : Problème écran.

L'écran reclignote, tous les fils sont bien insérés j'ai revérifié tous les câbles sont bien mis dans les logements. L'écran clignote d'ailleurs sans aucun carter... je ne pige pas la .

Dernière modification par Wiryn (04-07-2020 19:22:24)

Hors ligne

#6 04-07-2020 19:21:36

Gaara14
Administrator

Re : Problème écran.

Éventuellement aussi, s'il était possible que vous postiez une photo de la surface sous l'écran, ça serait plus simple pour voir d'ou vient le défaut.
Merci !

Hors ligne

#7 04-07-2020 19:26:37

belzebuteu
Moderator

Re : Problème écran.

J'ai aussi ce soucis d'écran qui clignote parfois. Je n'ai pas encore tout démonté pour verifier le cablage.

Pour la souris folle, je pense qu'en tournant la tablette en la tenant par les bords, on fait pression quelque part et on recréer un contact écran/dalle tactile. Je viens de faire le test.

Hors ligne

#8 04-07-2020 19:33:29

Gaara14
Administrator

Re : Problème écran.

Oui, il y a aussi ce problème de cadre avant. Une nouvelle version existe, avec 0,5mm de marge en plus, ce qui écrase moins l'écran quand on prend la tablette sur les côtés.
Je l'ai découvert que trop tardivement, et tous les cadres étaient déjà imprimés. J'ai donc décidé de livrer avec les cadres avec ces 0.5mm.

Ce qu'il est possible de faire en attendant mieux, c'est de ne pas trop serrer les vis du cadre. Et de prendre la tablette sans trop serrer les bords.

Hors ligne

#10 05-07-2020 10:32:45

alannerf
Membre

Re : Problème écran.

Bonjour, j’ai assemblé hier le Diskiopi, 20 min de travail et j’y ai installé un Raspberry pi 4Go sur Buster, le top!
Le manuel d’assemblage pourrait être amélioré pour les débutants avec du texte et la désignations plus claires des vis ! Sinon c’est ok smile le plastique de la coque fait assez bas de gamme, probablement du à la méthode d’impression 3D mais pas de soucis on s’en doutait. wink

J’ai eu les mêmes soucis sur l’écran tactile, avec des coupures intempestives et la souris qui s’affole. J’ai rapidement compris qu’il s’agissait d’interférences du cable miniHdmi vers la carte fille! J’ai essayé des stratégies pour faire un blindage de fortune (voir photo1) avec du papier aluminium qui améliore un peu les choses mais ne règle pas tout!

Par contre, en mettant un bon cable blindé (photo2) tout est rentré dans l’ordre! Mais plus possible de fermer le dos, il faut que je trouve un plus petit cable. Un conseil pour l’équipe diskiopi: revoyez votre cable et fournissez en un bon smile pour le futur. A part ça tout est ok, je commence à tester le diskio pi comme plateforme de dev sur raspberry et je reviendrai vous donner des news.

L’autonomie en charge moyenne semble ok vers 5-6h (à reconfirmer avec des tests plus précis). Bravo!
Bon courage à tous les Diskiopi users.

Dernière modification par alannerf (05-07-2020 10:37:03)

Hors ligne

#11 05-07-2020 10:45:07

alannerf
Membre

Re : Problème écran.

Blindage aluminium à tester
https://imagizer.imageshack.com/img924/1693/qgogP7.jpg

Assemblage cable HDMI qui règle les problèmes de bruit
https://imagizer.imageshack.com/img924/8753/hY4eV3.jpg

Hors ligne

#12 05-07-2020 18:06:02

Gaara14
Administrator

Re : Problème écran.

Bonjour à tous,

Le souci de l'écran qui clignote ne m'est jamais arrivé. Est-t-il est possible que ça soit un branchement mal effectué ? Surtout la nappe de l'écran, elle se détache parfois. Il faut bien la sécuriser avec un morceau de scotch.

Au niveau du câble HDMI, je ne sais pas si un blindage peut changer quelque chose. Le fait de brancher un câble classique oblige à enlever la plaque du Raspberry, et je pense que c'est justement quand elle est fixé que les soucis arrivent.

En effet, les 4 loquets, quand ils sont bloqués, déforment un peu la coque. Du coup ça appuie légèrement derrière l'écran est c'est là que le tactile détecte quelque chose.

Pour régler le souci, j'ai réétudié le système et ajouté une retenue qui empêche la coque de se déformer quand on verrouille la plaque. Pouvez vous regarder si le souci peut provenir de là ? Je posterais une photo demain pour plus de clarté.
Dans le cas ou votre machine a ce défaut, il faudra surement changer une pièce (un boitier batterie, celui du haut) pour la version B.

Pareil pour le cadre avant, la version B règle le soucis de clics fantômes quand on prend la tablette sur les côtés.

La production est tellement longue qu'il y a une inertie terrible entre les versions. Je suis désolé pour ces soucis, j'espère pouvoir corriger tout ça !

Hors ligne

#13 05-07-2020 18:16:49

Gaara14
Administrator

Re : Problème écran.

Wiryn a écrit :

L'écran reclignote, tous les fils sont bien insérés j'ai revérifié tous les câbles sont bien mis dans les logements. L'écran clignote d'ailleurs sans aucun carter... je ne pige pas la .

Si l'écran clignote, c'est qu'il est peut-être sous alimenté. Regarde si les batteries sont bien chargées, ou fais un essai avec le chargeur branché.
Il faut faire toutes les vérifications par étapes, sinon on risque de louper des choses.

Hors ligne

#14 05-07-2020 18:44:12

belzebuteu
Moderator

Re : Problème écran.

Gaara14 a écrit :
Wiryn a écrit :

L'écran reclignote, tous les fils sont bien insérés j'ai revérifié tous les câbles sont bien mis dans les logements. L'écran clignote d'ailleurs sans aucun carter... je ne pige pas la .

Si l'écran clignote, c'est qu'il est peut-être sous alimenté. Regarde si les batteries sont bien chargées, ou fais un essai avec le chargeur branché.
Il faut faire toutes les vérifications par étapes, sinon on risque de louper des choses.


Guillaume, j'ai la même chose de mon côté. Pas de carter à l'arrière. Et alim branchée.
Branchement vérifié.
J'ai ajouté un aimant que j'avais en rab autour de la nappe HDMI. Sans réel succès.
Je vais essayer avec l'odroid, mais je n'avais pas remarqué ce soucis.

Pour info pb avec la pi4 4Go

Hors ligne

#15 05-07-2020 18:48:17

Gaara14
Administrator

Re : Problème écran.

Bizarre.
Et ça ne serait pas une histoire de source HDMI ? Peux tu essayer de forcer dans l'OSD soit HDMI 1, soit HDMI 2 à la place de "Auto" ?

Hors ligne

#16 05-07-2020 18:55:48

belzebuteu
Moderator

Re : Problème écran.

big_smile
Les grands esprits se rencontrent.
J'étais auparavant sur le CH1 qui correspond à HDMI2. C'est là ou j'avais des clignotements.
Je suis passé sur le CH2 soit HDMI1 et MAGIIIIIIIIIIIE.
Plus de scintillement pour le moment. Je laisse tourner pour voir.

@Wiryn: Peux tu nous dire sur quelle entrée tu es?

Hors ligne

#17 05-07-2020 19:01:11

Gaara14
Administrator

Re : Problème écran.

Si ça marche, c'est donc que la carte est programmée par défaut sur le port le plus proche de l'alimentation usb, et pas celui que nous utilisons. Le firmware essaierait de temps en temps à se reconnecter sur le port par défaut, d'où la déco/reco.
C'est peut-être ça. A voir avec d'autres utilisateurs.

Hors ligne

#18 05-07-2020 19:35:42

belzebuteu
Moderator

Re : Problème écran.

Bon fausse alerte. J'ai eu encore des scintillements sur la pi4.

Je suis passé sur l'odroid et là rien depuis 20 minutes.

Je verrais bien une histoire de fréquence.

Hors ligne

#19 05-07-2020 19:58:21

Gaara14
Administrator

Re : Problème écran.

Ok alors c'est pas ça...
Mais ça scintille ou l'écran s'éteint et se rallume 1s après ?

As tu essayé l'autre port HDMI, soit de la Pi4, soit de la carte écran ?

Chez moi je n'ai rien remarqué de tout ça, c'est ce qui m'inquiète !

Hors ligne

#20 05-07-2020 20:46:28

Wiryn
Membre

Re : Problème écran.

belzebuteu a écrit :

big_smile
Les grands esprits se rencontrent.
J'étais auparavant sur le CH1 qui correspond à HDMI2. C'est là ou j'avais des clignotements.
Je suis passé sur le CH2 soit HDMI1 et MAGIIIIIIIIIIIE.
Plus de scintillement pour le moment. Je laisse tourner pour voir.

@Wiryn: Peux tu nous dire sur quelle entrée tu es?


J'ai testé les deux ports HDMI l'un après l'autre et j'ai le même soucis je check pour faire tourner la miche sous secteur. J'ai réésayé pour en avoir le coeur net je suis sur le HDMI 1 ça a l'air de tourner normalement je suis branché aussi en même temps par contre il faut même pas que j'essaies de mettre le carter à l'arrière sinon il redéconne et les bugs perdurent.

Dernière modification par Wiryn (05-07-2020 21:04:11)

Hors ligne

#21 05-07-2020 20:51:17

Gaara14
Administrator

Re : Problème écran.

Je posterais demain ma config.txt, pour comparer avec les votre. Notamment hdmi_group et hdmi_mode

Hors ligne

#22 05-07-2020 21:05:36

Wiryn
Membre

Re : Problème écran.

Les problèmes que j'ai ce sont des scintillements et non pas des coupures de plusieurs secondes. Et par la même occasion je suis avec un PI3 B+

Dernière modification par Wiryn (05-07-2020 21:06:31)

Hors ligne

#23 06-07-2020 15:00:59

Gaara14
Administrator

Re : Problème écran.

@Wiryn
Sous quel OS es-tu ?
Peux tu essayer ces paramètres dans ton fichier /boot/config.txt ?

hdmi_drive=2
hdmi_group=2
hdmi_mode=16

Si ça ne résout pas le problème, il faudra essayer de regarder / remplacer le câble HDMI.

Hors ligne

#24 06-07-2020 16:43:57

Wiryn
Membre

Re : Problème écran.

hdmi_group=2
hdmi_mode=83
hdmi drive 2
C'est ma configuration actuelle. Je suis sous Raspbian, en ce moment je suis sur la tablette et aucun flash du tout depuis que je suis passé sous HDMI 1. Je vais me mettre à écrire une article on va bien voir si j'ai encore ces problèmes qui reviennent

EDIT : il y a encore quelques flashs mais beaucoup moins fréquents.

Dernière modification par Wiryn (06-07-2020 17:01:30)

Hors ligne

#25 06-07-2020 16:53:39

Gaara14
Administrator

Re : Problème écran.

Ok, espérons que ça soit ça.
Tu as 83 en hdmi_mode ?
Sur mon Rpi3 j'ai cette ligne:

##     83                                       1600x900        reduced blanking

Je ne sais pas si l'écran supporte cette résolution, il fait FullHD donc 1920x1080 (donc 1080p) ou 720p.
J'aurais donc mis soit 16, soit 82, ou 85 pour du 720p.

Hors ligne

Pied de page des forums

Propulsé par FluxBB 1.5.11