Forum Diskio Pi

Another digital world is possible.

Vous n'êtes pas identifié(e).

#1 20-08-2020 14:24:14

humpff
Membre

[RESOLU] pas d'affichage sur écran a part deux fugaces pop ups chinois

bonjour à tous

Je suis en fin de montage du diskiopi et j'ai inséré le sbc (rpi4B)

par contre pas moyen d'avoir d'affichage, je n'ai pas encore testé séparément le pi. (j'ai swappé les connecteurs hdmi sur sbc comme sur la carte video)
au boot, j'ai deux pop ups de petite taille avec des caractères chinois qui s'affichent puis plus rien

je soupçonne un mauvais montage des connecteurs de l'affichage, j'ai la vue basse malgré mes lunettes et ces nappes sont si fragiles...

comment m'en assurer ? Si quelqu'un a une idée je tacherai de poster des photos plus tard au cas où une étourderie m'échapperai ?



merci !

Dernière modification par humpff (22-08-2020 17:39:48)

Hors ligne

#2 20-08-2020 14:37:01

Gaara14
Administrator

Re : [RESOLU] pas d'affichage sur écran a part deux fugaces pop ups chinois

Bonjour humpff,

Cela semble être un problème au niveau du signal l'HDMI.
Les deux popup indiquent "Pas de signal" et "Mise en veille" (la led rouge de l'écran l'indique).

Vérifiez bien la nappe HDMI, les connecteurs doivent être montés comme ceci, avec les loquets fermés :
IMG_20200813_182927.jpg
(sur la photo les loquets sont ouverts)

Un autre piège: Pour allumer la tablette avec le RPi interne, il faut pousser le bouton vers le bas, l'actionner vers le haut allume l'écran uniquement. Vérifiez donc que le RPi s'allume bien lorsque vous allumez la tablette.

Hors ligne

#3 21-08-2020 06:29:52

humpff
Membre

Re : [RESOLU] pas d'affichage sur écran a part deux fugaces pop ups chinois

bonjour,
La nappe est elle dans le bon sens sur la photo ? contacts vers le haut ?
autre question : cette nappe peut-être substituée ou bien est elle spéciale ?
la carte fille peut-être testée, non ? Si j'y connecte une sortie graphique de pc via du hdmi ?
merci !

Hors ligne

#4 21-08-2020 06:38:53

Gaara14
Administrator

Re : [RESOLU] pas d'affichage sur écran a part deux fugaces pop ups chinois

Oui, c'est bien contacts vars le haut.
La nappe est croisée, donc elle ne peut pas être remplacée par une autre.

En fait quand on parle de la carte fille, c'est la carte alimentation/HUB. Vous parlez surement de la carte écran wink
Oui, toute sortie HDMI peut être affichée par cette carte. Donc via un PC avec un câble classique pas de soucis, si le câble a un port mini HDMI.

Hors ligne

#5 22-08-2020 17:21:59

humpff
Membre

Re : [RESOLU] pas d'affichage sur écran a part deux fugaces pop ups chinois

bonjour Gaara ;=)

je poste trois photos illustrant le montage. Elles sont peu résolues, je peux essayer de zoomer si besoin.
D'autre part je vais essayer de faire afficher une autre source hdmi pour limiter les investigations, je suppose que c'est commutateur vers le haut pour n'alimenter que l'affichage ?



D9b54.jpg
qqrKe.jpg
g8lRj.jpg

à suivre

Hors ligne

#6 22-08-2020 17:38:59

humpff
Membre

Re : [RESOLU] pas d'affichage sur écran a part deux fugaces pop ups chinois

hello Gaaram

Problème résolu : l'affichage fonctionne ouf !!
en fait j'avais monté la nappe de liaison pi -> carte d'affichage à l'envers, connecteurs en bas (pensant bien faire)
j'ai eu peur car j'ai cassé le petit loquet plastique au démontage mais j'ai heureusement pu utiliser celui du connecteur mini que je n'utilise pas et qui est dans le kit.

Une question cependant y a t il un détail de montage du ventilateur fourni dans le kit, du PI4 ? Et où le connecter ? (je n'ai pas encore vraiment cherché)

Merci beaucoup, je vais pouvoir passer aux essais !!

si je peux me permettre une suggestion, ce serait de compléter la documentation du wiki en détaillant cela (en effet ce ne m'est pas apparu clairement lors de l'assemblage mais peut-être suis-je un peu trop distrait ?)

A suivre,

Humpff

Dernière modification par humpff (22-08-2020 17:40:38)

Hors ligne

#7 22-08-2020 17:46:30

Gaara14
Administrator

Re : [RESOLU] pas d'affichage sur écran a part deux fugaces pop ups chinois

Bonsoir hmpff,

Eh oui, la nappe HDMI était à l'envers wink
Je vais essayer de revoir le wiki et de préciser tout ça.

Pour le ventilateur, il se connecteur sur le port "FAN" de la carte fille.

Bons essais !

Hors ligne

#8 27-08-2020 17:57:31

humpff
Membre

Re : [RESOLU] pas d'affichage sur écran a part deux fugaces pop ups chinois

bonsoir !

je viens de finir les tests de départ (boot et mises à jour sur une microsd
avec raspbian) et tout semble fonctionner parfaitement.
(Note : apparemment le tactile n'est pas géré, je n'ai donc pas encore testé l'écran tactile.)

A suivre !

Hors ligne

#9 27-08-2020 18:39:28

belzebuteu
Moderator

Re : [RESOLU] pas d'affichage sur écran a part deux fugaces pop ups chinois

Bonsoir humpff.

L'écran tactile est géré nativement par Raspbian.
Es tu sûr d'avoir bien branché le câble usb?

Tu peux vérifier si le tactile est bien connecté avec la commande xinput list et tu devrais trouver le ILITEK Multi-Touch-V3000

pi@raspberrypi:~ $ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ ILITEK Multi-Touch-V3000                	id=7	[slave  pointer  (2)]
⎜   ↳ ILITEK Multi-Touch-V3000 Mouse          	id=8	[slave  pointer  (2)]
⎜   ↳ Logitech K400 Plus                      	id=6	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ ILITEK Multi-Touch-V3000 Keyboard       	id=9	[slave  keyboard (3)]
    ↳ Logitech K400 Plus                      	id=10	[slave  keyboard (3)]

Dernière modification par belzebuteu (28-08-2020 04:23:42)

Hors ligne

#10 27-08-2020 19:15:19

Gaara14
Administrator

Re : [RESOLU] pas d'affichage sur écran a part deux fugaces pop ups chinois

Bonsoir humpff,

Oui, le tactile est reconnu automatiquement normalement. Peux tu aussi nous donner le retour ce cette commande ? Pour voir si le HUB de la carte fille (Genesys Logic) est reconnu par le Raspberry Pi.

lsusb

Hors ligne

Pied de page des forums

Propulsé par FluxBB 1.5.11